Richmond Home

Update your Box Applications to Latest Version

03/31/2020

Starting on March 31, 2020, Box will block products and services using the TLS 1.1 encryption protocol. Box applications that are not up-to-date will stop working when this change is made. 

To ensure that your applications are not affected by this change, it is important that the applications are up to date.

The minimum versions that comply are:

Box Product

Minimum Compliant Version

Download Latest Version

End user impact on non-compliant version

Box Tools

Version 4

Mac: v4.1+

Windows: v4.1+

Download here.

Large scale deployments here.

Users will be unable to open files from Box.

For more details,

please see this article.

Box Sync

Mac: 4.0.7900+
Windows: 4.0.7900+

Download here.

Large scale deployments here.

Users will be logged out and will be unable to log in. The "Box Sync" folder will still exist but changes will not be synced. 

For more details, please see this article.

Box Drive

Mac: 1.7+

Windows:

1.13.84+

Download here.

Large scale deployments here.

 

Mac:

Users will be logged out and will be unable to log in

 

Windows:

Users may not be able to successfully update but all other functionality will continue to work.

 

For more details, please see this article.

Box for Office

Mac: N/A Box for Office is Windows only

Windows: 4.5.1227+

Download here.

Users will be logged out and will be unable to log in.

 

For more details, please see this article.

More information on this change can be found here:https://support.box.com/hc/en-us/articles/360044196673-Updating-Box-from-the-Transport-Layer-Security-TLS-1-1-Encryption-Protocol-FAQ